Zu Hauptinhalt springen

Systemanforderungen für Qlik NPrinting Engine

AUF DIESER SEITE

Systemanforderungen für Qlik NPrinting Engine

In diesem Abschnitt werden die minimalen Hardware- und Softwareanforderungen für Qlik NPrinting Engine aufgeführt.

Qlik NPrinting Engine kann sowohl auf physischen Computern als auch auf virtuellen Maschinen installiert werden. In beiden Konfigurationen werden virtualisierte Anwendungen nicht unterstützt. Die Qlik NPrinting Engine funktioniert beispielsweise nicht, wenn sie auf einem anderen Computer installiert wurde als QlikView Desktop und als virtualisierte Anwendung verteilt wird.

Standardmäßig ist nur eine Qlik NPrinting Engine pro Qlik NPrinting Server Lizenz verfügbar. Wenn Sie zusätzliche Engines zu Ihrer Qlik NPrinting Umgebung hinzufügen möchten, müssen Sie sie kaufen.

Voraussetzungen

Diese Anforderungen für Qlik NPrinting Engine gelten für Konfigurationen, bei denen jede Qlik NPrinting-Komponente auf einem anderen Computer installiert wird. Wenn Sie mehr als eine Komponente auf demselben Computer installieren (zum Beispiel den Server und die Engine), gelten höhere Mindestanforderungen.

  • Plattformen:
    • Microsoft Windows Server 2012
    • Microsoft Windows Server 2012 R2
    • Microsoft Windows Server 2016
    • Microsoft Windows Server 2019
  • Prozessoren (CPUs): x64-kompatible Multi-Core-Prozessoren mit mindestens zwei Kernen
  • Arbeitsspeicher: Mindestens 2 GB sind für jeden Kern erforderlich und insgesamt mindestens 4 GB RAM.
    • QlikView Desktop muss über genügend Arbeitsspeicher zur Verwaltung der QlikView-Dokumente verfügen, die Sie als Datenquellen für die Berichte verwenden.
    • Bei einem MultiDoc-Bericht handelt es sich um einen Bericht mit Daten aus vielen verschiedenen QlikView-Dokumenten. Wenn Sie MultiDoc-Berichte erstellen, werden alle QlikView Dokumente, die als Datenquellen verwendet werden, gleichzeitig geöffnet.

    • Die Verbindung mit zusätzlichen Qlik Sense Servern wirkt sich auf die Systemressourcen von Qlik NPrinting Server aus. Möglicherweise müssen Sie die RAM- und CPU-Nutzung für Qlik Qlik NPrinting Engine und Qlik NPrinting Server Computer erhöhen, wenn Sie eine Verbindung mit mehreren Qlik Sense herstellen.

  • Festplattenspeicherplatz: mindestens 300 MB
  • Speicherplatz: Es wird nur Windows-Speicher unterstützt, entweder lokal oder gemeinsam genutzt.
  • Serveruhren:

    Die Serveruhren von Qlik NPrinting Server und Qlik NPrinting EngineWindows müssen mit einer Toleranz von zwei Sekunden synchronisiert werden. Ein Windows-Server synchronisiert seine Uhr mit der Domänencontrolleruhr. Die Uhren sind also synchronisiert, wenn sich Qlik NPrinting Server und Qlik NPrinting Engine in derselben Domäne befinden. Entfernen Sie diese Option nicht manuell. Wenn Sie Qlik NPrinting Server und Qlik NPrinting Engine in unterschiedlichen Windows-Serverdomänen installieren, müssen Sie sicherstellen, dass die Uhren innerhalb einer 2-Sekunden-Toleranz synchronisiert werden.

  • Plattformsicherheit: TLS 1.2 muss aktiviert sein.
  • Hinweis: Lizenzaktivierungen erfordern Zugriff auf den Qlik Licensing Service. Öffnen Sie Port 443 und lassen Sie ausgehende Aufrufe an license.qlikcloud.com zu.

    Die Verwendung eines Proxys wird unterstützt. Weitere Informationen zur Einrichtung eines Proxy-Dienstes unter Windows finden Sie unter Proxy-Einrichtung für den Lizenzierungsdienst.

QlikView Kompatibilität mit Qlik NPrinting

QlikView Desktop ist für die QlikView Verbindung mit Qlik NPrinting erforderlich und muss auf jedem Qlik NPrinting Engine-Computer installiert sein.

Wenn Sie Server- oder Clusterverbindungen verwenden, benötigen QlikView Server und QlikView Desktop die gleiche Version.

Die folgenden Versionen von QlikView werden für die Verbindung mit Qlik NPrinting unterstützt:

  • QlikView November 2017 (12.20) oder höher

  • QlikView November 2018 (12.30) SR1 oder höher

  • QlikView April 2019 (12.40) oder höher

  • QlikView April 2020 SR2 (12.50 SR2) oder höher
  • QlikView May 2021 (12.60) oder höher
  • Warnung: QlikView Desktop Personal Edition wird nicht unterstützt.
    Warnung: QlikView in SaaS-Editionen von Qlik Sense wird nicht unterstützt

Wenn Sie von QlikView NPrinting 16 zu Qlik NPrinting November 2019 oder höher migrieren, müssen Sie möglicherweise ein Upgrade Ihrer QlikView Version durchführen. Siehe: Upgrade von QlikView NPrinting 16 vor der Migration.

Qlik Sense Kompatibilität mit Qlik NPrinting

Die folgenden Qlik Sense-Versionen werden bei der Verbindung mit Qlik NPrinting unterstützt: Beachten Sie, dass Ihre Qlik NPrinting-Version mindestens der Qlik Sense-Version unter Windowsentsprechen muss:

  • Qlik Sense Enterprise on Windows November 2017 oder höher.
  • Qlik NPrinting 17.2.1 oder höher ist für eine Verbindung mit Qlik Sense 3.1.2 oder neuer erforderlich.

  • Qlik Sense 2.3 oder höher ist erforderlich zum Herstellen von Verbindungen zu Qlik Sense Apps.

  • Qlik Sense 3.0.1 oder höher ist zum Verteilen von Berichten an einen Qlik Sense-Hub erforderlich.

  • Qlik Sense 3.1 oder höher ist erforderlich, wenn Sie eine Verbindung zu mehreren Qlik Sense Servern herstellen.

Für die Verbindung von Qlik Sense mit Qlik NPrinting ist keine Clientsoftware erforderlich.

Hinweis: SaaS editions of Qlik Sense und Qlik Sense Enterprise on Kubernetes werden für die Verbindung mit Qlik NPrinting nicht unterstützt.

Zusätzliche installierte Software

Die folgende Software wird während des Qlik NPrinting Engine-Setup installiert, sofern sie nicht bereits installiert ist. Sie darf nicht gelöscht werden:

  • PDF X-CHANGE 5.0.269
  • .NET-Framework: 4.7.2 oder höher

    Die .NET Framework-Version 4.7.2 wird installiert, wenn Sie Qlik NPrinting Server, Qlik NPrinting Engine oder Qlik NPrinting Designer installieren. Die Installation der .NET Framework-Version 4.7.2 erfordert eine aktive Internetverbindung. Falls die .NET Framework-Version 4.7.2 oder höher nicht bereits auf einem Computer ohne eine Internetverbindung installiert ist, schlägt die Installation fehl. Sie müssen die .NET Framework-Version 4.7.2 oder höher auf Computern ohne Internetverbindung installieren, bevor Sie Qlik NPrinting Server, Qlik NPrinting Engine oder Qlik NPrinting Designer installieren.Falls auf einem Computer, auf dem die .NET Framework-Version 4.7.2 oder höher installiert ist, keine Internetverbindung verfügbar ist, wird dieser Teil der Installation vom Installer übersprungen.