Veröffentlichen eines einfachen Berichts aus einem QlikView Dokument

In diesem Tutorial erfahren Sie, wie Sie mithilfe von QlikView-Daten einen einfachen Qlik NPrinting PowerPoint Bericht erstellen und veröffentlichen können.

Qlik NPrinting hat viele Funktionen. Dieses Tutorial soll neue Benutzer beim Erstellen ihres ersten Berichts unterstützen. Darin wird jedoch nicht jeder Berichtstyp, jedes Designelement oder jede Veröffentlichungsoption erläutert. Am Ende dieses Tutorials haben Sie einen PowerPoint-Bericht erstellt, bearbeitet und veröffentlicht, der von Ihren ausgewählten Benutzern angezeigt werden kann.

Weitere Qlik NPrinting Tutorials:

Hinweis: Microsoft Office muss installiert sein, damit Berichte in Office-Dateiformaten bearbeitet und erstellt werden können.

Dieses Tutorial verfolgt die folgenden Lernziele:

Zugreifen auf ein QlikView Dokument

Berichte benötigen Daten. Erfahren Sie, wie Sie ein QlikView Beispieldokument herunterladen und importieren.

Verbinden von Qlik NPrinting mit einem QlikView Dokument

Qlik NPrinting muss eine Verbindung zu Ihrem QlikView Dokument herstellen. Erfahren Sie, wie Sie Qlik NPrinting so konfigurieren, dass es Zugriff auf eine Beispieldokument oder Ihre vorhandenen QlikView Daten hat.

Erstellen einer neuen Qlik NPrinting Berichtsvorlage

Berichtsvorlagen bestimmen das Layout und die Ausgabeformate der Berichte. In diesem Abschnitt wird gezeigt, wie Sie einen neuen Bericht erstellen.

Bearbeiten der Berichtsvorlage

Berichte bieten viele verschiedene Formatierungsoptionen. In diesem Abschnitt fügen Sie einen Titel, Bilder, eine Tabelle, ein Diagramm und Seiten zu Ihrem Bericht hinzu.

Veröffentlichen in NewsStand und per E-Mail

NewsStand ist eine Webkonsole, die Benutzer zum Anzeigen von Berichten öffnen können. Erfahren Sie, wie Sie Ihren Bericht in NewsStand und per E-Mail veröffentlichen.

Zugreifen auf ein QlikView Dokument

QlikView Dokumente enthalten die Daten und Visualisierungen, mit denen Qlik NPrinting Berichte erstellt. Es gibt verschiedene Möglichkeiten, um auf ein QlikView Dokument zuzugreifen.

  • Sie können ein QlikView Dokument von der Qlik Hilfeseite herunterladen und in einem Ordner auf Ihrem Computer speichern.
  • Sie können Ihr eigenes QlikView Dokument verwenden und direkt zu Verbinden von Qlik NPrinting mit einem QlikView Dokument gehen. Wenn Sie Ihr eigenes Dokument verwenden, um dieses Tutorial abzuschließen, verwenden Sie ein einfaches Dokument. Bei komplexen QlikView Dokumenten kommt es bei Qlik NPrinting zu längeren Ladezeiten.

Herunterladen eines QlikView Dokuments von der Qlik Hilfeseite und Speichern des Dokuments auf Ihrem Computer

Gehen Sie folgendermaßen vor:

  1. Gehen Sie auf der Qlik NPrinting Hilfeseite zu Beispieldateien und laden Sie die Datei Examples.zip in den bevorzugten Speicherort auf dem Computer herunter, auf dem Qlik NPrinting installiert ist.
  2. Entzippen Sie in Windows die Datei Sales Demo.qvw und speichern Sie sie im Ordner C:\Programme\QlikView\Examples\. Falls der Ordner nicht vorhanden sein sollte, müssen Sie ihn erstellen.

    Falls Sie die Dateien an einem anderen Ort speichern, muss dieser Ort dann anstelle von C:\Programme\QlikView\Examples überall in der Qlik NPrinting Hilfe ersetzt werden.

Warnung: Zugeordnete Laufwerke wie Z:\NPrintingServer\QlikViewDocuments werden von Qlik NPrinting nicht unterstützt. Sie müssen stattdessen UNC-Pfade (Universal Naming Convention) wie \\ServerName\NPrintingServer\QlikViewDocuments verwenden.

Verbinden von Qlik NPrinting mit einem QlikView Dokument

Nun erstellen wir eine Qlik NPrinting App und verbinden diese mit Ihrem QlikView Dokument.

Die Qlik NPrinting Apps enthalten Berichte, Filter und Verbindungen zu Qlik Sense Apps oder QlikView Dokumenten. Damit kann Qlik NPrinting Designer auf Ihre Daten zugreifen, sodass sie in einem Bericht verwendet werden können.

Gehen Sie folgendermaßen vor:

  1. Melden Sie sich bei der Qlik NPrinting Webkonsole an.
  2. Klicken Sie im Hauptmenü auf die Dropdown-Liste Apps und wählen Sie Apps aus.
  3. Klicken Sie auf die Schaltfläche App erstellen.
    1. Geben Sie einen Namen für die neue App ein. Beispiel: Anfänger-Tutorial – NP-App – QV.
    2. Lassen Sie das Kontrollkästchen Aktiviert aktiviert. Andernfalls wird Ihre App von der Qlik NPrinting Engine ignoriert.
    3. Klicken Sie auf Erstellen.

      Anfänger-Tutorial – NP-App – QV wird unter Apps angezeigt.

  4. Klicken Sie im Hauptmenü auf die Dropdown-Liste Apps und wählen Sie Verbindungen aus.
    1. Klicken Sie auf die Schaltfläche Verbindung erstellen.
    2. Geben Sie im Feld Name einen Namen für die Verbindung ein: Verbindung zu Anfänger-Tutorial – QV.
    3. Wählen Sie in der Dropdown-Liste App die Qlik NPrinting App aus, die Sie zuvor erstellt haben: Anfänger-Tutorial – NP-App – QV.
    4. Wählen Sie unter Quelle die Option QlikView aus.
    5. Wählen Sie unter Typ die Option Lokal.
    6. Geben Sie unter Dokumentpfad den Speicherort des QlikView Dokuments ein, zu dem Sie eine Verbindung herstellen möchten.

      Beispiel: C:\Programme\QlikView\Examples\Sales Demo.qvw

      Warnung: Zugeordnete Laufwerke wie Z:\NPrintingServer\QlikViewDocuments werden von Qlik NPrinting nicht unterstützt. Sie müssen stattdessen UNC-Pfade (Universal Naming Convention) wie \\ServerName\NPrintingServer\QlikViewDocuments verwenden.
    7. Wenn Ihr QlikView Dokument Authentifizierung erfordert, vergewissern Sie sich, dass Die Verbindung muss authentifiziert werden aktiviert ist.

      Siehe: Section access.

    8. Klicken Sie auf die Schaltfläche Überprüfung ausführen. Dadurch wird sichergestellt, dass die Verbindung gültig ist.

      Falls die Verbindung gültig ist, wird die Meldung „Überprüfung erfolgreich“ angezeigt. Falls nicht, wird die folgende Meldung angezeigt: „Fehler erkannt. Überprüfen Sie die unten aufgeführten Details.“

    9. Nachdem Ihre Verbindungseinstellungen überprüft wurden, klicken Sie auf Erstellen. Sie kehren automatisch zum Menü Verbindungen zurück.
    10. Die neue Verbindung hat den Status Cache-Status – Wird erstellt. Das heißt, dass Qlik NPrinting eine Verbindung zu QlikView herstellt und Metadaten importiert. Bei einem großen QlikView Dokument dauert dieser Vorgang möglicherweise einige Minuten.
      Hinweis:

      Jedes Mal, wenn Sie neue Objekte zu Ihrem QlikView Dokument hinzufügen, müssen Sie die Verbindungsmetadaten erneut laden.

    11. Sobald der Cache-Status Erzeugt lautet, können Sie eine neue Berichtsvorlage erstellen. Falls ein Fehlerstatus angezeigt wird, überprüfen Sie die Verbindungsinformationen.

Jetzt können Sie Ihre neue Verbindung im Bildschirm Verbindungen anzeigen.

Falls bei der Herstellung der Verbindung zu Ihrem QlikView Dokument Probleme auftreten, finden Sie Informationen dazu unter:

Erstellen einer neuen Qlik NPrinting Berichtsvorlage

Berichtsvorlagen bestimmen das Layout und die Ausgabeformate der Berichte. Über die Standardoptionen des ausgewählten Berichtstyps können Sie Objekte anordnen und Seiten formatieren. Ein PowerPoint-Bericht hat zum Beispiel dieselben Formatierungsoptionen und dieselbe Benutzeroberfläche wie ein PowerPoint-Folienstapel.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie in der Qlik NPrinting Webkonsole im Hauptmenü auf Berichte.
  2. Klicken Sie auf die Schaltfläche Bericht erstellen.
  3. Geben Sie im Feld Titel einen Titel ein. Beispiel: Anfänger-Tutorial – NP-PowerPoint.
  4. Wählen Sie in der Dropdown-Liste Typ die Option PowerPoint aus.
  5. Wählen Sie in der Dropdown-Liste App den Eintrag Anfänger-Tutorial – NP-App – QV aus.
  6. Klicken Sie unter Vorlage auf die Option Leere Datei.
  7. Lassen Sie das Kontrollkästchen Aktiviert aktiviert. Andernfalls wird Ihr Bericht von der Qlik NPrinting Engine ignoriert.
  8. Klicken Sie auf Erstellen.

Unter Berichte wird jetzt Anfänger-Tutorial – NP PowerPoint angezeigt.

Bearbeiten der Berichtsvorlage

Es gibt viele Möglichkeiten zum Bearbeiten einer Berichtsvorlage. Wir fügen Folgendes hinzu:

  • Titel: einfacher Text, der zum Organisieren des Berichts verwendet wird. Titel können mit den Standardformatierungsoptionen in PowerPoint geändert werden.
  • Tabellen: Stellen Ihre QlikView Daten im Tabellenformat dar.
  • Bilder: Stellen Ihre QlikView Daten im PNG-Format dar.
  • Diagramme: Präsentieren Sie Ihre QlikView Tabellendaten als PowerPoint-Diagramm.

  • Seiten: Unterteilen Ihrer Daten nach Dimension. Ebenen können auf Tabellen und Bilder angewendet werden. In diesem Beispiel wird nach Jahr und Kategoriename unterteilt.

In diesem Abschnitt werden nicht alle Möglichkeiten behandelt, die Qlik NPrinting Designer für die Berichtsvorlage bietet. Informationen über erweiterte PowerPoint-Berichtsfunktionen finden Sie unter: PowerPoint-Berichte.

Hinweis: Ihre Berichtsvorschau sieht möglicherweise anders aus als das unten angezeigte Bild, je nachdem, wie Sie es formatiert haben. Manche Objekte haben möglicherweise etwas abweichende Namen, je nachdem, in welcher Reihenfolge sie ausgewählt wurden.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie in der Qlik NPrinting Webkonsole im Hauptmenü auf Berichte.
  2. Klicken Sie auf der Seite Berichte auf den gewünschten Bericht.
  3. Klicken Sie auf die Schaltfläche Vorlage bearbeiten, um den Qlik NPrinting Designer Vorlageneditor zu öffnen.

  4. Der Qlik NPrinting Designer wird geöffnet. Da Sie einen PowerPoint-Bericht erstellen, wird die PowerPoint-Standardbenutzeroberfläche angezeigt. Die meisten PowerPoint-Formatierungsfunktionen können über diese Benutzeroberfläche auf den Bericht angewendet werden.
  5. Geben Sie einen Titel ein:
    1. Geben Sie auf der ersten Folie einen Titel ein: Zum Beispiel „Sales Trends by Product Category“.
    2. Geben Sie einen Untertitel ein oder löschen Sie das Untertitel-Textfeld.

      Tipp: Sie können mit den PowerPoint-Formatierungsoptionen das Aussehen dieser Titel ändern. Sie können beispielsweise die Schriftgröße und -farbe ändern.
  6. Fügen Sie Bilder hinzu:
    1. Klicken Sie auf der PowerPoint-Symbolleiste auf die Registerkarte Einfügen.
    2. Klicken Sie auf die Schaltfläche Neue Folie.
    3. Geben Sie einen Titel ein, z. B. "Top Selling Products". Löschen Sie das zweite leere Textfeld.
    4. Klicken Sie im linken Fenster mit der rechten Maustaste auf Bilder und wählen Sie Objekte hinzufügen aus.

    5. Ein neues Fenster wird geöffnet. Wählen Sie Products und Sales by Category for 2014 vs 2013 aus und klicken Sie auf OK.

      Sie können mehrere Optionen auswählen, indem Sie die STRG-Taste gedrückt halten.

    6. Ziehen Sie SH02 - Products auf die Folie.

    7. Klicken Sie auf der PowerPoint-Symbolleiste auf die Registerkarte Einfügen.
    8. Klicken Sie auf die Schaltfläche Neue Folie.
    9. Geben Sie einen Titel ein, z. B. "Sales by Category: 2013 vs 2014". Löschen Sie das zweite leere Textfeld.
    10. Ziehen Sie CH212 - Sales by Category for 2014 vs 2013 auf die Folie.

  7. Fügen Sie eine Tabelle hinzu:
    1. Klicken Sie im Vorlageneditor mit der rechten Maustaste auf Tabellen und wählen Sie Objekte hinzufügen aus.
    2. Ein neues Fenster wird geöffnet. Wählen Sie Sales by Category: 2013 vs 2014 aus. Klicken Sie auf OK.

    3. Ziehen Sie CH212_1 - Sales by Category for 2014 vs 2013 auf die Folie.

  8. Fügen Sie ein natives PowerPoint-Diagramm hinzu:
    1. Klicken Sie auf der PowerPoint-Symbolleiste auf die Registerkarte Einfügen.
    2. Klicken Sie auf die Schaltfläche Neue Folie.
    3. Geben Sie einen Titel ein, z. B. "Sales Trends:". Löschen Sie das zweite leere Textfeld.
    4. Klicken Sie im Vorlageneditor mit der rechten Maustaste auf Tabellen und wählen Sie Objekte hinzufügen aus.

    5. Ein neues Fenster wird geöffnet. Wählen Sie CH326 - Sales by YearMonthNum aus. Klicken Sie auf OK.

    6. Wählen Sie auf der PowerPoint-Symbolleiste die Registerkarte Einfügen aus.
    7. Klicken Sie im Bereich Illustrationen auf Diagramm.
    8. Ein neues Fenster wird geöffnet. Wählen Sie unter Spalten das erste Balkendiagramm aus und klicken Sie dann auf OK.

    9. Ein Excel-Arbeitsblatt wird geöffnet. Dies ist die Datenquelle für Ihr Diagramm.

      In dieses Arbeitsblatt müssen Qlik NPrinting Tags eingefügt und einige unnötige Daten entfernt werden.

    10. Erweitern Sie im linken Bereich der PowerPoint-Benutzeroberfläche den Knoten CH326 - Sales by YearMonthNum.
    11. Wählen Sie die Tags YearMonthNum und Sales aus.

      Sie können mehrere Optionen auswählen, indem Sie die STRG-Taste gedrückt halten.

    12. Ziehen Sie das Year MonthNum-Tag per Drag and Drop in das Excel-Arbeitsblatt in die Zelle A1. Damit wird die Y-Achse erstellt. Ziehen Sie die Sales-Tags in die Zelle B1. Damit wird die X-Achse erstellt.

    13. Wählen Sie die Spalten C and D aus und löschen Sie sie.

      Die Zahlen selbst sind nicht nötig, da Qlik NPrinting die Tags zum Erstellen des Diagramms verwendet.

    14. Wählen Sie die Zeilen 3, 4 und 5 aus und löschen Sie sie.

    15. Schließen Sie Excel.

      Die Änderungen werden automatisch gespeichert.

    16. Möglicherweise müssen Sie die Größe des Diagramms anpassen, damit es auf die Folie passt. Verwenden Sie die Pfeile für die Größenanpassung.

    17. Klicken Sie im Menü des Qlik NPrinting Vorlageneditors auf die Registerkarte Datei. Klicken Sie auf Speichern.
    18. Klicken Sie auf die Registerkarte Vorlage und dann auf die Schaltfläche Vorschau, um eine Vorschau des Berichts anzuzeigen.

      Die Präsentation enthält zur Zeit vier Folien.

  9. Fügen Sie Seiten hinzu:
    1. Gehen Sie zu der Folie, der Sie die Seite hinzufügen möchten. In diesem Fall ist dies die vierte Folie.

      Seiten werden nur auf die aktuelle Folie angewendet.

    2. Klicken Sie im linken Bereich mit der rechten Maustaste auf Seite und wählen Sie Seite zu aktuellem Arbeitsblatt hinzufügen aus.
    3. Ein neues Fenster wird geöffnet. Wählen Sie CategoryName. Klicken Sie auf OK.

      Hinweis: Hinweis: Wenn Sie eine zweite Seite zu einer Folie hinzufügen, wird die vorige Seite überschrieben.
    4. Erweitern Sie den Knoten CategoryName_Page - CategoryName. Ziehen Sie das Tag CategoryName in die Folie.

      Durch dieses Tag werden Ihre Daten nach Kategorie unterteilt, wobei jede Kategorie auf einer eigenen Folie angezeigt wird. Der Text <CategoryName> ändert sich entsprechend der Kategorie auf der betreffenden Folie. Statt einer Folie mit dem Titel "Sales Trends:" sind jetzt mehrere Folien mit eindeutigen Titeln ("Sales Trends: Baby Clothes", "Sales Trends: Women's Shoes") vorhanden.

      Das Tag <CategoryName> wird als neues Textfeld angezeigt. Wenn Sie diesen neuen Text ausschneiden und in das Titeltextfeld einfügen, können Sie ihn leichter formatieren, damit er dem Titel entspricht.

    5. Gehen Sie zur zweiten Folie "Top Selling Products".
    6. Klicken Sie im linken Bereich mit der rechten Maustaste auf Seite und wählen Sie Seite zu aktuellem Arbeitsblatt hinzufügen aus.
    7. Ein neues Fenster wird geöffnet. Wählen Sie Year. Klicken Sie auf OK.
    8. Erweitern Sie den Knoten Year_Page - Year. Ziehen Sie das Tag Year auf die Folie.

      Es wird als neues Textfeld angezeigt. Wenn Sie diesen neuen Text ausschneiden und in das Titeltextfeld einfügen, können Sie ihn leichter formatieren, damit er dem Titel entspricht.

    9. Klicken Sie auf der PowerPoint-Symbolleiste auf die Registerkarte Einfügen.
    10. Klicken Sie auf die Schaltfläche Foliennummer.
    11. Ein neues Fenster wird geöffnet. Aktivieren Sie die Kontrollkästchen Datum und Uhrzeit, Foliennummer und Auf Titelfolie nicht anzeigen. Klicken Sie auf Auf alle anwenden.

  10. Klicken Sie im Menü des Qlik NPrinting Vorlageneditors auf die Registerkarte Datei. Klicken Sie auf Speichern.
  11. Klicken Sie auf die Registerkarte Vorlage und dann auf die Schaltfläche Vorschau, um eine Vorschau des Berichts anzuzeigen.

    Das Laden der Vorschau kann je nach Größe Ihres Berichts einige Minuten dauern.

    Sie haben jetzt einen Bericht mit 13 Folien. Die Folien, auf die Seiten angewendet wurden, wurden um neue Seiten mit Informationen erweitert, die durch die angewendeten Seitenkategorien unterteilt sind.

    In diesem Beispiel zeigen die Folien 2-4 nach Year gefilterte Daten, die Folien 6-13 nach CategoryName gefilterte Daten.

    Warnung: Änderungen im Vorschaumodus werden nicht gespeichert.
  12. Wenn Sie den Bericht weiter bearbeiten möchten, schließen Sie das Vorschaufenster und formatieren Sie ihn im Vorlageneditor.
  13. Wenn Sie die Bearbeitung des Berichts abgeschlossen haben, klicken Sie auf Speichern und schließen.

Die Berichtsvorlage wird jetzt gespeichert und kann mit anderen Benutzern geteilt werden.

Veröffentlichen in NewsStand und per E-Mail

Berichte müssen veröffentlicht werden, damit Benutzer auf sie zugreifen können. Wir werden in NewsStand und per E-Mail veröffentlichen.

NewsStand ist ein Webportal, über das sich Benutzer eine Vorschau von Berichten anzeigen, Berichte herunterladen und automatische Aktualisierungen abonnieren können. Siehe: NewsStand-Überblick

E-Mails enthalten Ihre Berichte als Anhänge. Die Inhalte der Berichte können durch Hinzufügen von Text und Bildern angepasst werden. Siehe: Verteilen von Berichten per E-Mail.

Hinweis: Sie müssen Ihren SMTP-E-Mail-Server konfigurieren, damit E-Mails aus Qlik NPrinting versendet werden können. Siehe: Konfigurieren Sie den SMTP-Server.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie im Hauptmenü der Qlik NPrinting Webkonsole auf Aufgaben und wählen Sie Veröffentlichen-Aufgabe aus.
  2. Klicken Sie auf die Schaltfläche Aufgabe erstellen.

    1. Geben Sie einen Namen ein. Beispiel: Anfänger-Tutorial – NP-PowerPoint veröffentlichen.
    2. Wählen Sie Ihre App in der Dropdown-Liste aus. Anfänger-Tutorial – NP-App – QV.
    3. Behalten Sie die Standardwerte der anderen Optionen bei. Klicken Sie auf Erstellen.
  3. Klicken Sie auf die Registerkarte Reports.
    1. Klicken Sie auf die Schaltfläche Bericht einfügen.

    2. Wählen Sie Beginner's Tutorial - NP PowerPoint aus der Dropdown-Liste Bericht wählen.
    3. Wählen Sie in der Dropdown-Liste Ausgabeformat die Option PPTX aus.
    4. Vergewissern Sie sich, dass die Kontrollkästchen An E-Mail anhängen und Aktiviert aktiviert sind.
    5. Klicken Sie auf Bericht einfügen.

  4. Klicken Sie auf die Registerkarte Benutzer/Gruppen.
    1. Klicken Sie auf die Schaltfläche Benutzer oder Gruppe einfügen.
    2. Wählen Sie einen Benutzer oder eine Gruppe in der Dropdown-Liste Empfänger wählen aus.

      Wenn Sie erfahren möchten, wie Sie neue Benutzer erstellen, finden Sie Informationen dazu unter: Erstellen von Benutzern.

    3. Aktivieren Sie die Kontrollkästchen Aktiviert, NewsStand-Empfänger und E-Mail-Empfänger.
    4. Klicken Sie auf Empfänger einfügen.
  5. Klicken Sie auf die Registerkarte Ziele.
    1. Klicken Sie in der NewsStand-Spalte auf das Kontrollkästchen Für alle veröffentlichen.
    2. Klicken Sie in der E-Mail-Spalte auf das Kontrollkästchen Für alle veröffentlichen.
    3. Klicken Sie auf Speichern.
  6. Daraufhin wird die Registerkarte Übersicht angezeigt.
  7. Klicken Sie auf die Schaltfläche Jetzt ausführen.

    Nachdem die Aufgabe abgeschlossen ist, wird oben auf der Seite eine Bestätigungsmeldung angezeigt.

Die Empfänger können nun in ihrem jeweiligen Browser den NewsStand aufrufen und Ihren Bericht anzeigen. Außerdem erhalten sie den Bericht per E-Mail.

Tipp: In Standardinstallationen können Sie von der Qlik NPrinting Webkonsole zu Ihrem NewsStand wechseln, indem Sie in der Browserleiste den Port von 4993 zu 4994 ändern. Wenn beispielsweise Ihre Webkonsole https://YourServerName:4993 ist, dann ist Ihr NewsStand https://YourServerName:4994.