Erstellen eines Excel-Pivottabellenberichts mithilfe von Ebenen

Sie können native Excel-Pivottabellen in Ihren Berichten erstellen.

Bei der Datenquelle einer Pivottabelle muss es sich um ein QlikView- oder Qlik Sense-Tabellendiagramm handeln, damit einzelne Spalten verwaltet werden können. Falls Sie eine Pivottabelle in einem Excel-Bericht neu erstellen möchten, haben Sie zwei Möglichkeiten:

  • Die ursprüngliche Pivottabelle in eine einfache Tabelle konvertieren.
  • Die Pivottabelle klonen und den Klon in eine einfache Tabelle konvertieren.

Erstellen eines neuen Excel-Berichts

Gehen Sie folgendermaßen vor:

  1. Wählen Sie Berichte im Qlik NPrinting Hauptmenü aus und klicken Sie auf Bericht erstellen.
  2. Geben Sie einen Titel für den Bericht ein. Pivot table report with levels.
  3. Wählen Sie in der Dropdown-Liste Typ Excel aus.
  4. Wählen Sie eine App aus der Dropdown-Liste App aus.
  5. Klicken Sie auf Erzeugen, um den Bericht zu erzeugen.
  6. Klicken Sie zum Öffnen des Template Editor auf Vorlage bearbeiten.
  7. Klicken Sie mit der rechten Maustaste auf den Knoten Ebenen und wählen Sie anschließend Ebenen hinzufügen aus.
  8. Wählen Sie die Verbindung zum QlikView-Dokument aus, das das gewünschte Objekt enthält.
  9. Wählen Sie Straight Country - Salesman - Year - CH205 in der Ebenenliste aus.
  10. Klicken Sie auf OK.

Erstellen einer Tabelle auf der Grundlage der Ebene

Gehen Sie folgendermaßen vor:

  1. Ziehen Sie das Knotensymbol CH205_Level - Straight Country-Salesman-Year in leere Vorlagenzellen. Dadurch werden öffnende und schließende Tags für die Ebene erstellt.
  2. Erweitern Sie den Knoten CH205_Level - Straight Country-Salesman-Year, indem Sie auf das + links daneben klicken.
  3. Ziehen Sie die Knotensymbole Country, Salesman, Year und Sales in leere Zellen auf Zeilen zwischen den Zeilen, die die Tags <CH205_Level> und </CH205_Level> enthalten.
    Hinweis: Im Fenster Eigenschaften muss die Einstellung Quellformate beibehalten für alle vier Objekte deaktiviert sein.
  4. Geben Sie Überschriften für die Spalten in der Zeile über der Zeile ein, die das <CH205_Level>-Tag enthält.
  5. Wählen Sie einen Zellenbereich aus, der die Zeilen mit den Überschriften, das Tag <CH205_Level>, die Spalten-Tags und das Tag </CH205_Level> enthält.
  6. Geben Sie dem Bereich im Feld ganz Links über dem Vorlagenfenster einen Namen.
  7. Drücken Sie die Eingabetaste auf Ihrer Tastatur.
Hinweis:

Tabellen, die dynamische Dimensionen oder Null-Werte haben, können als Ebenen verwendet werden, allerdings können Sie keine Objekte oder Ebenen darin ablegen. Auf diesen Ebenen, die sich aus normalen und dynamischen Dimensionen (und anderen Ausdrücken) zusammensetzen, können Sie nur deren Felder hinzufügen. Sie können keine Bilder, Tabellen oder Formeln hinzufügen.

Erstellen einer Pivottabelle

Gehen Sie folgendermaßen vor:

  1. Wählen Sie Tabelle2 aus oder fügen Sie es bei Bedarf hinzu.
  2. Öffnen Sie das -Excel Menüband, indem Sie das Symbol Symbolleiste auswählen.
  3. Wählen Sie im Menüband die Registerkarte Einfügen aus.
  4. Wählen Sie PivotTable im Fenster Tabellen aus.
  5. Geben Sie den Namen ein, mit dem Sie den Bereich in Tabelle1 im Feld Tabelle/Bereich benannt haben.
  6. Klicken Sie auf OK.

Hinzufügen von Feldern zu einer Berichtsvorlage

Gehen Sie folgendermaßen vor:

  1. Ziehen Sie die Felder Country und Salesman in das Feld Zeilenbeschriftungen.
  2. Ziehen Sie das Feld Year in das Feld Spaltenbeschriftungen.
  3. Ziehen Sie das Feld Sales in das Feld Werte.
  4. Klicken Sie auf das Symbol Feldeinstellungen in der Gruppe Aktives Feld.
  5. Ändern Sie den Wert auf der Registerkarte Werte zusammenfassen nach zu Summe.
  6. Klicken Sie auf OK.

Festlegen der zu aktualisierenden Daten

Gehen Sie folgendermaßen vor:

  1. Wählen Sie die Schaltfläche Optionen in der Gruppe PivotTable aus.
  2. Wählen Sie im Menüband PivotTable-Optionen die Registerkarte Daten aus.
  3. Stellen Sie sicher, dass das Feld Aktualisieren beim Öffnen der Datei aktiviert ist.
  4. Achten Sie darauf, dass Anzahl der pro Feld beizubehaltenden Elemente mit Keine festgelegt ist.
  5. Klicken Sie auf OK.

Vorschau und Speichern

Gehen Sie folgendermaßen vor:

  1. Klicken Sie auf Vorschau.
  2. Überprüfen Sie den Bericht, schließen Sie ihn und bearbeiten Sie die Vorlage bei Bedarf erneut.
  3. Klicken Sie auf Speichern und schließen, um die Vorlage zu speichern und schließen Sie den Vorlageneditor.